Weird dual gpu issues

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Allotec

PCHF Member
PCHF Member
Jan 28, 2020
1
0
18
I have a laptop that has 2 graphics processors one integrated and a discrete mx250. I am at college so for my setup I brought 2 monitors to plug into my laptop through a usb tpe c hub. My laptop has a type c port that supports display port 1.2 so the monitors are working except for one small issue. Whenever i Plug my laptop into the type c hub I like to close it so my desk looks cleaner and I can just use the monitors. The issue is that the discrete graphics will not work on any other screen except for the one that is physically connected to the laptop. Whenver my laptop is closed I try to open nvidia control panel and it says you are currently not using a display connected to a nvidia graphics card. Which is really weird because when i go into device manager the computer detects that there is a mx250 installed. I have tried reinstalling drivers than connecting the monitors and also disabling the integrated gpu but that makes it so nothing works. Basically I want to be able to play csgo on my monitor but it wont run well unless I can use the discrete card please help.
Laptop used- 13-aq0044nr
I dont think monitors are that important
TLDR- The dual gpus in my laptop are acting weird and the discrete card will only work on the main laptop screen.
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
5,187
583
56
Welcome to PCHF Allotec,

Sounds like the notebook is going into low power state and the discrete GPU then not getting enough juice.

Is the Windows Power Plan set to High Performance and what do you have your power settings set up to do when you close the lid, see info here
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
5,187
583
56
Thread closed due to lack of any feedback from the OP.
 
Status
Not open for further replies.