PC restarting without telling the issue

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

enthusiast1988

PCHF Member
PCHF Member
Feb 10, 2019
12
1
Philippines
Hope you're all safe and healthy.

I hope to get your thoughts on why my PC might be restarting without displaying the issue after the restart? It would just go on as if nothing happened.

Would a faulty video card be the root cause? The video card is getting glitchy as it's a few years old and the display is turning to green screen sometimes (just solid color green, nothing else) and also it has turned to inverted colors once.

Could also be the Processor? It's 6 years old in tropical country so I suspect some wear due to heat and moisture. The mobo is new. The powersupply is as old as the processor, but if that is faulty, the system should have mentioned something about improper shut down, right?


Attached my system specs.
 

Attachments

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
2,669
648
127.0.0.1
pchelpforum.net
From what you describe could be the display card. If the system has build on display try removing the card and see if the same issue occurs.

What is the make and model of the PSU.

With the system being six years old could be that something is starting to fail.
 

enthusiast1988

PCHF Member
PCHF Member
Feb 10, 2019
12
1
Philippines
From what you describe could be the display card. If the system has build on display try removing the card and see if the same issue occurs.

What is the make and model of the PSU.

With the system being six years old could be that something is starting to fail.
PSU is Orion 650VA I don't have model name anymore. I took a picture of it.
 

Attachments

enthusiast1988

PCHF Member
PCHF Member
Feb 10, 2019
12
1
Philippines
Where did this come form when I do a search all I find is battery backups.

What were the results?
Sorry I don't have anymore info about the UPS.

I am yet to try removing the video card. Need a dvi to hdmi adapter which I should have this week and will let you know after testing. Thank you
 
Status
Not open for further replies.