Solved New USB webcam - mic not working, not found

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

pje1654

PCHF Member
PCHF Member
Jun 7, 2020
10
0
41
I recently bought a Logitech C270 HD webcam, brand new. I cannot get its built-in mic to work. Video works fine but no mic is detected. I've made sure it's enabled in Device Manager. And under PC Settings>Privacy>Microphone, 'Let applications use my microphone' is set to On. I've installed the relevant drivers several times with no luck (had to do it from a 3rd party site as the Logitech support site isn't working properly). Zoom and Skype can't detect the mic. Neither can Sounds or Sound Recorder in Windows (running 8.1). When I run Troubleshooter, Windows says the mic is Disabled (which I can see it isn't).

I tried updating the onboard Realtek audio drivers from HP (my PC is a HP Pavilion 500-515) in case there was some sort of conflict, but that made the speakers stop working, with the same problem as the mic - Windows said they were disabled, which they weren't. Is there a setting hidden away in Windows that's disabling new audio devices? Any help appreciated.
 

vger

PCHF Manager
PCHF Manager
PCHF Donator
Jul 21, 2016
5,996
872
www.etsy.com
Hello

It is a possibility that that mic,might be defective.. Did the cam come with software? Also as soon as possible i would replace that third party driver.. These are known to have a lot of useless ad's/software in them as soon as Logitech site is working properly.. It may come down on using the warranty and get a replacement..
 

pje1654

PCHF Member
PCHF Member
Jun 7, 2020
10
0
41
It didn't come with any software. The drivers & software I used are the Logitech ones, but from a different site as the Logitech site is unusable. Initially I thought the mic might be defective, but then after trying to update the sound card drivers I had the exact same problem with the speakers as I've got with the webcam mic - they were not recognised, and windows thought they were disabled, even though they weren't. I sorted that by doing a System Restore and the speakers work fine, as they had done before. So I think it's some sort of problem within windows when trying to update the audio drivers/software
 

vger

PCHF Manager
PCHF Manager
PCHF Donator
Jul 21, 2016
5,996
872
www.etsy.com
Ok and it also could have been that 3rd party site you went to for those drivers causing your issues before you rolled back..
 

pje1654

PCHF Member
PCHF Member
Jun 7, 2020
10
0
41
Fixed. For anyone with a similar problem, I found the solution here:

This is what worked:

Go to Start>Search and type 'cmd'. Search will return cmd.exe. Right click on this and select 'Run as Administrator'. At the prompt type:

net localgroup Administrators /add networkservice
press enter then type:
net localgroup Administrators /add localservice
press enter then type:
exit
press enter and restart your computer

Thanks for the replies, vger
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,361
1,833
pchelpforum.net
Glad you got it sorted. Thanks for letting us know, solved
 
Status
Not open for further replies.