• Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pending OP Response Network not discovering computers?

Elliethesnowfairy

PCHF Member
PCHF Member
Aug 7, 2018
2
0
21
#1
Hi I'm having an issue where I cannot see all the devices on my network under Network in Files Explorer.

My desktop is connected to the router via Ethernet cable.
My laptop is connected to the router via Wifi.
The laptop is a Microsoft Surface Pro. The desktop is a custom build. Both computers are running Windows 10 professional.

On the laptop, if I go to File Explorer, I can see both the laptop, the desktop, and another computer listed "Network"
On the desktop, if I go to File Explorer, I can only see my own computer but it's listed as a Media Device instead of "Computer"

The reason this is a problem is that I need to be able to transfer files across my network, including printers.

How can I get my laptop visible on the desktop, and the desktop not to be shown as a Media Device?


I have already done the flush dns, winsock reset, register dns commands.


EDIT: posted this in the wrong area. My apologies!!!
 
Last edited:

Bruce

Forum Regular
PCHF Advisor
PCHF Member
Oct 8, 2017
427
106
26
Yeppoon, QLD, Australia.
#2
you need to allow File and Printer Sharing on all devices.

start an elevated command prompt and type these;
> powershell "Set-NetConnectionProfile -NetworkCategory private"
> netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes
> netsh advfirewall firewall set rule group="Network Discovery" new enable=yes

see if that works.
if not, type this command as well;
> control /name Microsoft.NetworkAndSharingCenter /page advanced
and in the All Networks section, click "Turn on sharing so anyone with network access..." and click "Turn off password-protected sharing" if you don't want that extra layer of protection.
 
Likes: jmarket

Bruce

Forum Regular
PCHF Advisor
PCHF Member
Oct 8, 2017
427
106
26
Yeppoon, QLD, Australia.
#4
what are the security programs on each PC?
are you trying to access a particular folder on the laptop or at the moment, simple trying to see the laptop at least?

you should be able to put something in each PC's Public folkder and see that file from all PC's on the same network.