Installed a new MoBo and downloaded all the updates for it, restarted Computer and then Mouse and Keyboard don't work at login screen

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Johnde5000

PCHF Member
PCHF Member
Aug 3, 2019
1
0
24
I have looked and looked for simple fixes, but I keep finding this and that, that just don't. Getting sick of seeing PS/2 keyboard and mouse should work, try that. I'm not going to try a PS/2 mouse/keyboard cause I don't want to. I also don't own one and I guarantee I won't find one.

Mobo - ASUS ROG Strix B450-F Gaming Motherboard (ATX) AMD Ryzen 2 AM4 DDR4 DP HDMI M.2 USB 3.1 Gen2 B450

Typical start of the computer.... keyboard/mouse lights are on. Bios splash screen... on... Windows loading screen... lights off... Windows login screen... lights off and nothing works.

Restart... open bios.... try this.. that... not working on login screen.

restart.. try windows recovery options, etc. keyboard doesn't work when that starts up.

Obviously it's not the mouse and keyboard. It was literally me updating the mobo after I got it all hooked up at the beginning.

I have tried just about everything that I've found on various websites and nothing has worked.. I just upgraded my pc and all I want to do is actually use it....................................................
 
Last edited by a moderator:

JIMMY LOUGHRAN

PCHF Member
PCHF Member
Oct 25, 2017
14
2
75
Hi John, I had a similar problem. I downloaded a Linux Distro to put with my windows 7 system for a duel boot. When I rebooted to start my windows system, the Razor keyboard and mouse did not work. I had to reboot it a few times before they came on. Now, I found that it was the Linux which was the problem as it is not compatible with Razor. From what I read you had to put some sort of code in, so I knocked it on the head. I put Windows 10 on today to duel boot with 7. Not sure if what I told you was any use, but good luck.
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
3,698
1,748
Sydney, Australia
pchelpforum.net
Also when installing another motherboard to an existing system Windows must be reinstalled to work properly.

Any update for us?
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
3,306
482
56
Thread closed due to lack of any feedback from the OP.
 
Status
Not open for further replies.