In Progress Help I have no signal

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
I’ve just built my first pc and I was going to install windows but when I turned it on I got no signal on my monitor I looked it up and tried unplugging and replugging,taking out the ram,and gpu hoping it would just be a connection error but still the same no signal message

HELP THIS WAS SO EXPENSIVE!!!
Motherboard:gigabyte A320m-S2H
Gpu:Radeon RX 570
CPU:Ruzen 3

Mr.Stark I don’t feel so good☹☹
 

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
yep everything turns on,fans work even the led light strips I installed are working which is why I’m so confused
 

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
Honestly I don’t even really know what that means, what are chipset drivers? I wasn’t told anything about them or how to install it

I sound stupid sorry
 

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
Yea the P.C. turns on the fans spin correctly,and no I haven’t tried swapping the cables I don’t have a second one at my disposal I was hoping it would just be something stupid but I’ll buy a second one as soon as I get paid hopefully that’s the issue
 

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
Honestly I’m not even sure where I’d find it I checked the box and the paper it came with but maybe I’m just not seeing it
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,361
1,833
pchelpforum.net
Not saying it is for sure, but. There is a possibility that your cpu is not supported without a bios update. That means you would need a cpu that is known to work with an early bios so you could update the bios to a version that supports your current cpu?

Before going down that path remove all the parts from your case and assemble the pc on a non conductive surface such as cardboard. Assemble it WITHOUT the graphics card and plug the monitor into the motherboard graphics port. test it.
 

Dswayv

PCHF Member
PCHF Member
Jun 30, 2020
8
0
20
Removed the graphics card and still didn’t get a signal

I got this build off a Joey Delgado videoans no ones had problems from what I can see in the comments I think I might’ve just messed up while putting it together or maybe a faulty wire
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,361
1,833
pchelpforum.net
Before going down that path remove all the parts from your case and assemble the pc on a non conductive surface such as cardboard. Assemble it WITHOUT the graphics card and plug the monitor into the motherboard graphics port. test it.