Solved BSOD system32 /ntoskrnl.exe is missing or corrupt

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
So my pc was working completely fine. I shut it down via windows and came back an hour later and turned it one. I got the MSI boot screen, and then the screen went black (but i still had a video signal) and sat like that for about 4 minutes, i checked my mobo debug lights and nothing was lit up so it wasn't anything with the motherboard or memory or CPU, I got impatient and hit the reset button on my front panel.
The computer booted back up and I immediately got a bsod with the above message "system32 ntoskrnl.exe is missing or corrupt". I ran chkdsk from a thumbdrive and it didn't detect any errors, I specifically used c:/chkdsk/f/r/x to check and repair any errors, but again it said there was no errors. So I exited chkdsk and tried booting back into windows normally and I got the same bsod.
I tried booting into safe mode and it went into safe mode and the screen flickered about 20 times and then my computer shutdown. My Windows version is the 1909 update which I installed after unstalling the 2004 updated becuase I was having problems. I just installed the 1909 version a couple weeks ago and it's been working fine. Am i correct in assuming that I once again am going to have to reinstall Windows? And if so can I just do the install that doesn't delete all my files and apps? To be honest I'm not really worried about my personal files since I have them all on a different drive, but installing all my apps again is gonna take hours.
And here's an idea, could I use a linux live cd, grab that system32 file off a Windows 10 iso, and using the linux live cd just replace the file on my os HDD with the file from the Windows 10 CD?
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
Update. I decided to try safe mode again, this time I got the BSOD windows\system32\drivers\iaStorAVC.sys is corrupt or missing, I restarted the computer.....and the **** thing booted up no problem. I AM SOOOO CONFUSED, what is going on with this computer??? Can someone recommend a scan I can do and submit, because I am truly at my wits end, i really don't understand what is going on with this thing. Once in Windows I once again did a disk error scan and once again it said no errors detected on any of my hard drives. I really don't get it. Should I do a Windows refresh just incase?
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
Hello

Hopefully some of our members will chime in soon..

@jmarket @phillpower2
I ended up reinstalling Windows. After reinstalling I created a restore point, created a recovery USB and am now looking for a free program to clone my windows install, settings and programs to save me a couple hours of reinstalling everything incase this happens again (I just posted a thread asking about that)
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
After creating the backup my system seemed to be running fine. Later in the day I decided to rearrange my room. Turned off the computer, turned off the PSU, unplugged it, rearranged room, plugged it back in. When it booted back up I noticed my desktop was altered, because my resolution was reset to default, I changed it back, then I noticed there was some problem with the audio since the audio icon was red exed out I right clicked it and selected the audio output the screen flashed and it said it couldn't find the source. So I ran a troubleshooter it didn't do anything. I then decided to restart the computer, immediately after restart I got a bsod, the same as the one I've been getting. And this is after a new windows install. I then tried to boot into safe mode and got another bsod and 3 other ones, kernal security check failure, drivers/mvumis.sys, and one other one I didn't catch in time.
I finally was able to boot into safe mode after about 5 tries, I ran sfc/scannow it said there were errors but they couldn't be fixed. I exited, restarted and it went straight to Windows no problem. I ran Samsung Magician's disk diagnostic, it came back clear, I ran chkdsk, it also came back clear. I then decided to download the actual Samsung driver for my drive so I could run a Smart scan, I downloaded installed it, had to restart, during the restart the computer crashed, same thing ntoskrnl, and after another restart my computer wasn't detecting my drive (I'm assuming because the driver install was interrupted) It wasn't showing in my BIOS as a boot option but was showing in the mobo layout diagram. I reset my CMOS and that fixed that.
I then tried installing my backup, it installed, I exited, it booted back up and got the same BSOD. So at this point I said screw it, I reinstalled Windows AGAIN for the third time in 24hrs. Right now it is working fine, but I am assuming my drive is bad at this point, so I went ahead and ordered a new drive. If theres any logs I can submit I'm glad to do it although I don't think theres any saved anymore since I reinstalled Windows. I am receiving the new drive tomorrow, I'll keep you updated if I get another bsod before that.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
Now that I reinstalled Windows again it's working fine. But that's how it's been, it works fine for a couple hours or a day or two and then it crashes. Since the reinstall last night I haven't tried safe mode yet. But I did just run sfc/scannow about a half hour ago just incase and it came back clear. At this point I haven't installed any programs, only Firefox and Chrome, also i haven't connected my other drives for storage yet. The only thing I have done is run windows update and install those two browsers. I am kind of wondering if the copy of windows I was using for the last couple installs was corrupt. For this most recent install I used a different copy I have that's from about a year ago. Right now I am playing it safe and not installing anything or creating any new files becuase I don't feel like going through the hassle of installing them just to have the system crash again.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
New update. I decided to go ahead and install the official AMD Ryzen Chipset drivers. After installing them, I restarted the computer (as it told me to). When I got to my desktop I noticed that once again my desktop was rearranged, my resolution was all messed up and my audio was exed out. I couldn't click anything, and the computer froze and I got a BSOD, saying the same thing it has been saying. So at this point I am wondering if it's an issue with AMD's Chipset drivers (I've installed them everytime in order to change my power profile to Ryzen Balanced). I am going to go ahead and flash my BIOs since I cleared my CMOS yesterday in order for my SSD to be recognized, and after flashing my BIO's to the most updated version I am going to see what happens. If it boots successfully, I'm going to try and install the amd chipset drivers again and see what happens. If the same thing happens then I think we narrowed the problem down to bad chipset drivers. And then I think it becomes a problem that has to be taken up with AMD.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
And it's working now. I flashed my BIO's to the latest stable version (I almost flashed a beta version) I checked power options and I have the Ryzen specific power options, so the chipset drivers were applied successfully. I ran sfc/scannow and it reported back no problems with system integrity. I am now going to restart the computer and see if I get a BSOD, also i'll boot into safe mode and see what happens.
Edit: Actually forgot all of that. is there any scan you would like me to do before I restart because I have a bad feeling it's eventually gonna bsod again, so I'm going to keep it on until i absolute have to turn it off or restart it.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
410
45
35
Wisconsin
I think at this point we can mark this solved. I'm 99% sure the problems I was having was due to bad RAM. I concluded this becuase during my last Windows install before I even had Windows on the hard drive I got the same bsod right when I booted up my computer to install windows from a flash drive. I realized I had XMP enabled, and also realized I have been having these BSOD problems every since I upgraded my RAM. So I went ahaed and returned the new M.2 sdd I had bought and I bought new RAM yesterday. To test if the RAM would work fine I ran MemTest 64 for 4 hrs and came back with no errors and no Bsods. I currently have the new RAM installed and XMP enabled and everything is working fine SO FAR. So I think this is officially solved. I appreciate all the help and info everyone gave. Thank You.
 
Status
Not open for further replies.