Automatic alt tabbing

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Bart755

PCHF Member
PCHF Member
Nov 11, 2020
1
0
31
Hi all,

(not sure if this is a virus or perhaps a windows 10 bug)

For the past 4 months or so whenever I play Overwatch or Phasmafobia, my game alt tabs automatically on the moments you really don't want it happening. So during the game, my PC will alt tab like this:
https://imgshare.io/image/NcGSsO

I tried all sorts of things to try and fix it:

1: Windows focus logger will log which programs are forcing a focus. However it simply mentions windows when it happens so it doesn't seem like a program is triggering it:
https://imgshare.io/image/NcKaA8

2: I disabled all "start-ups" as mentioned in step 6 on the following website: https://windowsreport.com/pc-automatically-alt-tabs/#:~:text=Press the Windows key %2B R > type msconfig and hit Enter,each app and click Disable.)
https://imgshare.io/image/NcGngX

3: I activated a script through the use of AutoHotKey as shown in the following youtube video to disable alt-tab and this actually works. So if I press Alt-tab now, NOTHING happens HOWEVER... When I play Overwatch it still automatically alt-tabs when i'm in the midst of battle.
// software AutoHotKey

4: I have Avast and did a full virus scan. No virusses found and I don't notice anything weird on my PC other than the automatic alt-tabbing.

5: running the game in borderless window / full screen / ... doesn't affect it


The weird part of this all is that I have this issue while playing Overwatch and Phasmafobia. This only seems to happen when the ghost/enemy player is really close to me. I know it sounds odd but I have had this problem for months now and it consistently only happens when a ghost/enemy player is really close to me in my crosshair... If I were to play a ranged character, it doesn't happen. If I play a close range combat character, it happends all the time. As you can imaging when you are about to kill someone and the game alt tabs... It ruins your gameplay.

I do have a keyboard + mouse with extra buttons but if I disabled the alt-tab through a script and it still happends, could it be due to the mouse or keyboard? And I also ofcourse tried pressing all sorts of key combinations trying to reproducte the situation but whatever I try, I cannot trigger the alt-tab myself (besides alt tabbing myself obviously). The keys I usually press during these situations are: z,q,s,d, mouse buttons, shift, maybe accidentally the left cntrl... but I tried everything...

I don't know what else to do. I did everything I could that I found on the internet... hopefully someone can help me here (otherwise I might just downgrade to win 7 since I read that others have similar problems with win10)

Thanks in advance for the assistance,

kind regards,
Bart
 

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
3,008
662
127.0.0.1
pchelpforum.net
For the Keyboard and Mouse while waiting for other to reply lets start with this in no particular order.

Wired or wireless

Cleaned the mouse and keyboard

tried a basic mouse and keyboard
(separate hoping to rule out each)

tried different ports

Some of the games that I have played have where that can be ignored not to sure where is indifferent locations.

Have you also checked the key bindings

Have you also checked the Sticky Keys under Settings then Ease of Access under Keyboard to make sure they are off.
 
Last edited:
Status
Not open for further replies.