Solved Weird colour display what do I do?

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
2,639
646
127.0.0.1
pchelpforum.net
Try booting in safe mode does it look about the same?
If the system has a display card remove that and connect to the onboard display of there is one.
Complete system specs would be helpful
Events leading prior and up to this happening
 

RyanL28

PCHF Member
PCHF Member
Jun 26, 2020
4
0
31
I've booted in safe mode, I've used the on board graphics, I've even reinstalled Windows, though this is being displayed even at the bios stage of booting up, I have a feeling it's either the PSU or motherboard, the GPU I think is fine it's a1080 ti and never had any problems, the ram is fine I have a motherboard with diagnofine because it still works absolutely sound because it's allowed me to not up and even reinstall windows
So I'm guessing it could be the PSU.
 

RyanL28

PCHF Member
PCHF Member
Jun 26, 2020
4
0
31
I7 7700k
Gtx 1080ti
Maximus hero 9 motherboard
32 GB Corsair vengeance 3000mhz
PSU Corsair CXM750
 

RyanL28

PCHF Member
PCHF Member
Jun 26, 2020
4
0
31
Figured it out .... It was my 4k TV
All the hdmi ports on it was tripping on acid I had to update the tv's firmware ... All is good so far
 
Status
Not open for further replies.