Solved VideoPad Taking Forever to Load

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
298
39
35
I just built an awesome video editing rig. I was using my underpowered laptop to edit video using VideoPad, it took seconds for VideoPad to load, but now on my new awesome rig it is taking over a minute for it to load. I don't get it, I have a better CPU, an actual graphics card now, faster RAM and I'm using a faster M.2 ssd, but for some reason the program takes over a minute to load. It has been fully updated and I have uninstalled and reinstalled it and it still does it, does anyone know what may be going on to cause this? Also once it loads it works fine, actually better and smoother then with my laptop.
 

vger

PCHF Manager
PCHF Manager
PCHF Donator
Jul 21, 2016
5,336
849
www.etsy.com
Hello

So once the Video Pad loaded on your laptop,it would not run correctly?? So the new rig loads slow but Video Pad works fine..

Please give us your spec's on your new rig and your laptop spec's for comparison .

@phillpower2 @Rustys
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
298
39
35
No, it's almost the complete oposite of what's going on now. On my laptop, it loaded in seconds but when editing it was slow to render and kind of jittery, and took over an hour to process the final edited video. On my new rig, it is slow to load, it takes over a minutes, but once it loads it works awesome, rendering is smooth, and the edited video only takes about 20mins to process. Its that slow load time that is really annoying me, there have also been times where it just doesn't load and I have to try 3 or 4 times before it finally does.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
298
39
35
okay, well I seemed to have fixed the problem. I ended up up installing a newer version of VideoPad, but the new version was acting really weird, so I looked at the version number and the new version turned out to be a beta version, so I downgraded back to the release that I had previously and now it loads fine. I'm not sure what was wrong with it becuase I had uninstalled and reinstalled before but it didn't solve it. But for some reason by upgrading then downgrading it seemed to have fixed it.
 
  • Like
Reactions: vger
Status
Not open for further replies.