Solved Screen goes blank randomly. See post for completed troubleshooting steps.

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
I bought a custom built PC for my GF off of Facebook. Everything seemed solid, I did my due diligence and felt confident in buying it. The PC worked fine for about 2 months and then the issue started. The problem is that the display will go blank. Sometimes, black, sometimes light blue, I've gotten even a yellow screen, and sometimes, not often, the display will come back but most times it won't. Sometimes it's 10 minutes of using it, sometimes an hour, and sometimes before I can even log in. If I'm on the BIOS settings, in safe mode, idle on the desktop, or the PC boot options screen, it seems fine but as soon as I do almost anything, it goes blank. The computer doesn't shut off but the display just goes blank. Monitor doesn't turn off either when screen goes blank.

Below are the Specs and tried troubleshooting steps I have taken.

The specs:
  • MOBO: Gigabye GA-X99-Designare EX
  • GPU: Gigabyte RTX 2070
  • CPU: Intel Core i7-6850k @ 3.60Hz
    • Liquid Cooled
  • RAM: 36 GB on DDR4 Corsaire Vengence
Troubleshooting steps:
  • First and foremost I tested HDMI cables to the monitor and the monitor itself.
  • Checked to make sure everything in PC was seated properly, GPU, RAM, all cables and that all fans worked.
  • Did a reset of PC, reinstalled everything.
  • Did a clean install of Windows and wiped all drives.
  • Made sure drivers and bios were updated.
  • Temperatures all look fine.
I've ran out of ideas. Please help!
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
Welcome toPCHF InFlux93,

Can you post the brand and model name or number of the PSU.

Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s.

To publish a Speccy profile to the Web:

In Speccy, click File, and then click Publish Snapshot.

In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.

Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Welcome toPCHF InFlux93,

Can you post the brand and model name or number of the PSU.

Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s.

To publish a Speccy profile to the Web:

In Speccy, click File, and then click Publish Snapshot.

In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.

Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.
I will do that here in an hour. Can I run speccy in safe mode or do I need to run it normally?
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
Normal boot (y)

Almost certain that we have your answer but do the test and answer the question that was asked in any event.

Can I ask that you do not quote every reply, it really does not help any and just makes for unnecessary reading, thanks.
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
The PSU is a Corsaire AX1200

I've been trying to download Speccy for a bit now but I can't get the image to stay long enough for me to even open the browser. It goes blank before I can type in the URL.

Also, thanks for the welcome by the way. :giggle:
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
My apologies InFlux93, please disregard my reply #4, Ive been waiting on two Speccy urls and replied to the wrong thread :(

Got a couple of things for you to do but we cannot do them until Windows is fully up to date and we know whether or not after installing Windows you then installed the divers for the MB and starting with the chipset drivers first.

Operating System
Windows 10 Home 64-bit
Computer type: Desktop
Installation Date: 4/3/2020 11:58:00 AM

An example of one of the failed updates;

Not Installed
4/3/2020 2020-03 Cumulative Update for Windows 10 Version 1909 for x64-based Systems (KB4551762)
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Unfortunately the update won't install. It gets to 100% then says "There were problems installing some updates, but we'll try again later." I tried running the update troubleshooter but it didn't detect any issues.

I went to the Microsoft Update Catalog and downloaded a standalone installer for the update and that failed as well.
2020-03 Cumulative Update for Windows 10 Version 1909 for x64-based Systems (KB4541335)
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Sorry the update you pointed out in post #7 is different from what the current update on my PC says. I check that one too.
I tried a stand alone installer for KB4551762 and it says that the update is already installed on the computer.
Update KB4541335 is the current update that won't install on my PC with error 0x800f0900
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
No worries, Speccy lists a few failed updates.

Your best option is to download the latest ISO and do a clean install of Windows 10 and the drivers for the MB, ISO info here no need to enter any product key as you have already been running Windows 10 on the computer, I would though as a precaution make sure that you have the product key written down and kept somewhere safe.
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Is what I did different from what you are suggesting? I had created a Windows 10 Media Installation Tool, formatted the drive and reinstalled Windows 10 a couple days ago.
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
Something is amiss somewhere else Windows would be able to install updates and while it is you are fighting a losing battle as any one of a number of the missing updates could be the hotfix that you need to put things right.

In case not aware, apart from the chipset drivers for a MB Windows 10 will search for and download/install drivers for most Windows 10 compatible hardware, one problem with this is though Windows can download and install driver updates for the GPU when not needed and the result quite often is that you start having issues.

Going offline soon as I have a real early start but will check back after work tomorrow but before I go can you answer the following in red that was mentioned previously;

Got a couple of things for you to do but we cannot do them until Windows is fully up to date and we know whether or not after installing Windows you then installed the divers for the MB and starting with the chipset drivers first.
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Initially I did not. I went ahead and tried installing them about 20 minutes ago and the issue still persists. I will go ahead, do a clean install of Windows, install the chipset drivers, and check to see if Windows is or will update.

Thank you for your time today. I'm really grateful!
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
So I reinstalled Windows and as far as I can tell, I had no issues installing all the Windows Updates.

I also installed the drivers for the MB but to be honest, I'm not 100% certain I did it properly or if I installed the correct drivers. I downloaded and ran a INF Update program that was a "Intel Chipset Device Software" associated with this particular MB. And the BIOS are up to date as well.

Anyways, here is an updated Speccy file. http://speccy.piriform.com/results/Yb7Kw1yWjuR4upKGOns68wW

The error still persists of the screen going blank randomly :(
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Observation while using the PC: It seems that the screen only goes blank when an application is opened. Weather it's the browser, or any utility program. But if I am in just the setting of the PC, things seem to be fine.
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
You have at least resolved one problems with the Windows updates now installing so hopefully we are making inroads, your computer is certainly better protected against malware.

Not sure why but your GPU is shown to only have 4GB of VRAM which is not possible as all versions have 8GB, this could be a driver issue.

A question for you and a suggestion for you to check, I do have a couple of other ideas but the outcome of the first check may give us clue as to whether or not we are on the right track.

Q: Speccy shows that Windows has installed Nvide drivers for your video card, did you give it permission to, bad idea if you did but also bad idea if you didn`t as Windows 10 has a habit of installing unnecessary and/or incompatible drivers that cause folk no end of grief.

Suggestion, restart the computer in Safe Mode only (No Networking) and test, make a note of any issue/s that may occur then again restart the computer in Safe Mode but this time with Networking, test and then post back with an update for us if you will.

You are welcome btw :)
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Good morning.

So, in response to your question, I don't think I ever explicitly gave permission for automatic updates purposely. But I did check and I think that they are on. See attached photo. Do I need to switch it to no?
Capture.PNG


In regards to testing the PC in both safe modes, no issues exist while running in safe mode. Computer runs fine, no random blank screens.
 

InFlux93

PCHF Member
PCHF Member
Apr 3, 2020
20
2
27
Clearwater, Florida
Also, just out of curiosity I did some of my own research. According to a couple of forums, it is reported that the appropriate VRAM capacity doesn't display correctly on most spec scanning software. I downloaded GPU-Z and below are the specs that are being read through that software:
GPU.gif

As you can see the memory size is displaying 8192MB and not half of that.
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
6,874
657
56
Hi InFlux93,

You can safely change that to No as there is only Microsoft who will be upset by it as they will have less control of your computer :D

Things being ok in both versions of Safe Mode suggests that this is either a software (inc drivers) or a settings option that is tripping things up, possibly the drivers that Windows installed.

Create a new folder on the desktop, named Nvidea drivers.

Download and save to the folder a different version of the drivers to those that you presently have from your GPUs website.

Download DDU from here

Create a new system restore point then run DDU and uninstall all present Nvidea drivers.

Restart the computer in Safe Mode only (No Networking).

Install the new GPU drivers that you saved to the folder on your desktop.

Restart the computer, test then post back with an update for us.

Thanks for the GPU-z info, was aware of such anomalies but we do need to mention anything that we see in case someone else thinks that we have missed it.
 
Status
Not open for further replies.