Ryzen 7 3800X on MSI x570 Will Not Post.

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

DSHLive

PCHF Member
PCHF Member
Dec 9, 2019
1
0
23
I have recently purchased my first build from Newegg including a barebone Ryzen 7 3800x with a cooler master 212 preinstalled onto a MSI X570 A-Pro. After adding all the parts noted below neither case or CPU fans spin plus no activity with the MB at all when wired up and turned on. Not sure what to think here. Any advice would be greatly appreciated.

I have already tried the paperclip test on the PSU and it works properly so that's not it. Also tried jumping the two power pin connectors with a screwdriver for the case power button but nothing. Again not sure where this leaves me here. I would hate to think it's a faulty MB.

Ryzen 7 3800x
MSI X570 A-Pro
Nvidia 2080 Super Ventus
G-Skill Trident Z 16G 3200
Samsung 970 pro Evo M.2
Corsair CX750M
Fractal Meshify C
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
4,939
574
56
Welcome to PCHF DSHLive,

Are the following three connections securely attached to the PSU and into the sockets on the MB.

1x 24-pin ATX main power connector
1x 8-pin ATX 12V power connector
1x 4-pin ATX 12V power connector
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
4,939
574
56
Thread closed due to lack of any feedback from the OP.
 
Status
Not open for further replies.