RAM shows up in BIOS but not in Windows

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

origilgun

PCHF Member
PCHF Member
Oct 18, 2020
1
0
27
I had 2x8GB sticks in my computer and I decided to buy 2 additional modules and add them (same model exactly).

My motherboard Asus H170m-Plus recognizes the new modules (shows up in BIOS) but they are not showing up in the total memory in the operating system which is Windows Server 2019.
System properties shows only 16GB total but if I run CPU-Z for example it recognizes all 4 sticks of 8GB.

Am I missing some BIOS setting?

Thanks in advance.

ram.PNG
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
7,781
705
57
Windows Server 2019 is for IT specialists and business users and not for personal use which is the only type of user that we are permitted to help.

As per the PCHF Terms and rules

15. PCHF can not and will not offer advice for business use or financial gain. PCHF only offers assistance for personal use.

Legitimate users of Microsoft Server can only be assisted by either their IT department or by Microsoft directly, this thread will be closed as per the PCHF Terms and rules.
 
Status
Not open for further replies.