Poor video quality?

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Romeo21

PCHF Member
PCHF Member
Aug 23, 2018
1
0
22
Hello all,

(Apologies admins if wrong section)

I've recently had my PC fitted with a Nvidia GTX 1070 by the PC manufacturer (I'd know nothing about hardware). I used to have a Nvidia GT 750 (something along the lines of that) so I wanted the upgrade. The new graphics card is going amazingly, I can play all my games on ultra graphics with no frame drops and they look beautiful. The issue I'm having is that when I record video using various softwares (Fraps, OBS and XSplit) the finished videos are always poor quality. When I record I get a good FPS and no lag however the video files are bad quality such as this that I recorded earlier (sound is fine but muted as can hear myself). I have updated all my drivers, played with different settings but there's no luck. Before the graphics card was changed, I had no issues and could record with videos being full HD looking just like the game.

My computer features are as follows:
- Nvidia GeForce GTX 1070
- AMD FX(tm)-4300 Quad-Core Processor
- 8GB RAM
- 1920x1080, 60Hz

As I say when I record the games, the games are amazing quality but the videos are bad.

I appreciate any help :)

Thank you
Romeo21, Sean
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,181
1,810
pchelpforum.net
Perhaps you should check your settings again on your recording software, and what media player are you using to replay your movies?

The youtube video you linked to is fine on my end.
 

aashimagupta

PCHF Member
PCHF Member
Aug 29, 2018
11
1
23
Update the software and the drivers again. Check the resolution setting for recording in the software. Maybe they are low.
 

phillpower2

You can call me Ad
Administrator
Support Team
Sep 9, 2016
5,669
592
56
Any update for us? This thread will be closed if not replied to within 48hrs.
 
Status
Not open for further replies.