• Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Solved Older PC no Output

Not open for further replies.


PCHF Member
Jun 21, 2020
Hi, I know theres a lot of these posts but I cant find a definite answer. I'm not that savvy with PC building so bear with me.

My PC is about 5 years old now never had any problems. I don't use it much recently.

After not turning it on for a few months, a few months ago Windows wouldn't start so I completely reinstalled and no problems.

I stopped using my PC again for a while, and turned it on last week no issue still. I'm working from home and have an ethernet cable for my work PC after normally using wifi on my own one. I thought why not and plugged the ethernet cable into my personal PC while it was on.

I clicked on the internet options in the bottom right of the start bar, and just had that loading circle. I couldn't click anything but programs were still running in the background.

I waited a few mins and restarted my PC.

Initially windows would not boot, and the system would try and run auto repair but this didn't work. After a few restarts ready to reinstall windows it started turning on for a few seconds, then off and restarting in a loop. Looking around I tried with removing the motherboard battery to reset the CMOS, and also moved the RAM. After removing and replacing the battery, it now switches and stays on, although for the first turn on after being off for a while it does turn off and restart once.

All the LED's and Fans are on but there is no output, using the graphics card outputs or motherboard. I can verify my monitor is working fine.

There is no beep, a POST beep I believe?, and I'm not sure if what the problem could be. Looking around I understand it could be the PSU or motherboard, but I don't have a lot of money. Sorry for the long post, but question is, is this most like the motherboard or PSU? I am looking to replace one of them but don't want to waste money. I understand it could be either but does anyone know what is most likely? Thanks

Some info on my PC:

Intel i5- 4460 Processor

Gigabyte H81M-S2H Motherboard.

Corsair CX600 Power Supply

Zotac Geforce GTX 970 Graphics Card

Team Elite 8GB 1600Mhz Memory
Couple of questions if I may;

Is your RAM a single 8GB stick or two 4GB sticks.

The specs for your MB don`t show it to have an onboard speaker, did you retro fit one **, have you ever heard any beeps from the computer.

** See attachment.

Can I ask that you do not quote every reply as I have to read the full post to make sure nothing gets missed,, thanks.


  • MB BIOS speaker (2018_02_02 10_53_58 UTC).jpg
    MB BIOS speaker (2018_02_02 10_53_58 UTC).jpg
    28.6 KB · Views: 5
It is a single 8GB Stick.

I haven't fitted my own speaker. It definitely makes a sound on start up normally. And when I accidentally did not put the ram in correctly there was multiple beeps from the PC. Again I am sorry I am not too knowledgeable with this kind of things.

I apologise, I will no longer do that.
So if you remove the single stick of RAM you get error beeps, if yes, this normally means that things are ok up to the point that the RAM and memory slots have been tested as part of the power on self test (POST) and that the problem is after this, the graphics is the next to get checked so if you get no beeps with the RAM in the board it looks to be graphics related.
Yep, removing the RAM causes a series of beeps, but no sound if the RAM is in the board.

This still happens even with the GPU removed. Do you think it could be a problem with the motherboard? From looking at other places I can see this may be an issue with the power supply as well, just not supplying enough power for everything. Thanks.
You are of course free to follow what you read on any other forums but if you are receiving direct assistance from any of them let us know and we will chime out.

The questions that have been asked are part of a process of elimination and atm there is nothing to suggest that this is a PSU problem, if it were a MB or a PSU problem you would not be getting any error beeps from the MB.

In case not aware, the integrated video on a MB relies on the RAM and in this instance the CPU for support so it is still possible that the RAM or the memory slot on the MB have a problem.

Have you tried the RAM in the other slot on the MB.

What video port on the MB are you using VGA, DVI or HDMI.

What type of screen are you using, a dedicated computer display or a TV.

Do you have a keyboard connected to the computer, a faulty or missing keyboard can cause POST to fail and if using a USB keyboard it should be connected to the black USB 2.0 type port and when possible a wired PS/2 type keyboard should be used when troubleshooting.
So far I have read on forums through people with similar problems as me, this is the only place I am receiving help, and I do appreciate it!

I have tried the other slot in the RAM before and it made no difference. I just tried it again in the other slot, and I suddenly had the POST beep and there was output letting me know BIOS had been reset. I switched off the PC and back on again to change input and its back to how it was, without me touching the RAM.

I usually use DVI but I have tried VGA and its the same problem. I was using VGA when POST beep worked a second a go. I do have a dedicated computer display, which has no HDMI input.

At the moment there is no keyboard or mouse input, but usually they are in the USB 2.0 in the back of the PC. I had just put a keyboard into the 2.0 slot in the back when the output started a min ago, but it no longer works with or without the keyboard. I do only have a USB keyboard at this time.
While troubleshooting you must have a keyboard connected to the computer or POST will fail, the mouse makes no difference.

I switched off the PC and back on again to change input and its back to how it was, without me touching the RAM.
Got to ask, why did you change anything once you had things working, the fact that you did not touch the RAM at all and you are not getting error beeps with RAM in the board but have no display again goes back to a video problem with the two ever present items being the video cable and the screen, suggest a close inspection of both.
Ok thank you, I was not aware of that, I left the keyboard plugged in now.

I know it is silly but as it started to work i had it on VGA connection, which I use for my work PC. (I can not use parts from that PC) and I wanted to switch back to my usual DVI. I wrongly hoped that changing the RAM slot had fixed the issue.

I use the same screen and VGA cable for my work PC with no issue, and simply disconnecting from that one to my personal one causes the same issue.
You are not meant to swap and change hardware connections all of the time and your present predicament is just one of the reasons as to why, things get worn, come loose and when it comes to swapping video connectors in and out the I/O plate at the back of the case can when worn or loose start causing earthing problems, hence why it is recommended to use a KVM switch.

If not done already, revert back to the VGA connector and see if you are able to get a display, even if it means shutting the computer down and swapping the RAM around a few times, note that you must follow the safety steps below at all times.

The following checks require the computer case to be opened so take the following safety precautions 1st, disconnect the power cord from the wall socket, press the case power button for twenty seconds or so to get rid of any residual charge in the system, take anti static precautions before touching anything inside, you can do this by touching a bare metal part of the case or PSU or if a notebook by touching a household radiator or associated copper feed pipe.
Thanks for your advice.

I have good news and bad news.

I found our moving the RAM from one slot to the other gives the POST beep, and system works fine. I was able to reinstall windows and run no issue even turning on and off.

Bad news as soon as I put the GPU back in I had the same issue. Once removed this carries on until I move the RAM slot again. It doesn't matter to which ram slot, as long as it swaps it works.

I have noticed when there is no POST beep or output, there is a clicking every few seconds, and a small LED just below the Ethernet port turns on whenever there is that sound. Not sure if this means anything.
Quick update

After not touching my PC or doing anything for a few hours with the GPU left out, I turned it on, and it continued to turn off and restart in a loop.

Again moving the RAM to the other socket fixed this issue.

After replacing the GPU and again doing the RAM thing its working fine with the output through the graphics card and not the motherboard. (This might be normal I guess)
Will just have to wait and see what happens for now, the behaviour is what you would expect from a poor contact or a loose connection.

I have noticed when there is no POST beep or output, there is a clicking every few seconds, and a small LED just below the Ethernet port turns on whenever there is that sound. Not sure if this means anything.
Could be a clue and especially as you mentioned the following in your OP;

I'm working from home and have an ethernet cable for my work PC after normally using wifi on my own one. I thought why not and plugged the ethernet cable into my personal PC while it was on.
A flaky Ethernet port could be stopping the computer from passing the POST, I would at some point disable the Ethernet port in the BIOS if the problem returns.
Thanks for your help, I've now disabled the LAN port ( I think this is the Ethernet port) in the BIOS and so far so good.

This seems to be causing the problem, but as my PC is old now, I think I'll get some upgrades soon!

I've removed the in progress prefix to this thread so I hope this counts as concluding it. Thanks again
Not open for further replies.