Solved No bootable device - restart system

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Cclementi

PCHF Member
PCHF Member
Jun 29, 2020
2
0
21
Hello,
2 months ago i had problem with "automatic repair" and i saw video on YouTube (
) and it helped me a lot. Now i got again that problem so i tryed that method again but this time i got "Access denied" at step "bootrec /fixboot" so i tryed method which is in comments but i still god "acces denied". Then i decide to skip that part and go to next one "attrib d:\boot\bcd - h - r - s" and i got massage "Unable to find d:\boot" (something like that). I tried to find in Internet solution and i find method with deleting something :
"diskpart
sel dis 0
sel par 1
del par override
cre par EFI
for fs=FAT32 quick
assign letter=T
exit
bcdboot C:\Windows /s T: /f ALL
exit"
I did this and after i turn off pc and turn on i got black screen with massage "No bootable device - please reset your system"
I know i screw it and i deleted something wrong, so what can i do now?
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,444
229
Yeppoon, QLD, Australia.
if the boot partition really did live on D:\ drive, your diskpart commands deleted it.
so your 'no bootable device' is because of that, and as vger mentions, the original cause could easily be a failing drive.

I would be doing a repair install of Windows (or even a fresh install), forgetting D:\, and putting everything on C:\

looks like C: and D: partitions are on the same physical drive.
 

Cclementi

PCHF Member
PCHF Member
Jun 29, 2020
2
0
21
Hello all,
thank you so much about taking your time to help me. I tryed much methods from forums and YouTube and no one works. I reinstalled my Windows fro m USB and now it works fine. Once again thank you for fast answer and help. :)
 
Status
Not open for further replies.