Solved Laptop Screen ALWAYS Goes Off, Even When Display Shutdown is on "Never"

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

reasonabletan

PCHF Member
PCHF Member
Feb 11, 2019
3
0
30
I noticed that my laptop screen display would always go off and require me to log back on after only a few minutes of not using it. This would happen much quicker than my Screen Display settings, which were originally at about 10 minutes or so. I wanted to test whether it was my settings or the laptop itself, so I put the Screen Display settings to Never turn off.

Low and behold, same problem. Still need to log back in after about 3 minutes or so of not using the laptop.

Does anyone know why this happens?
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
869
180
Yeppoon, QLD, Australia.
what is your OS?
have you tried going into Control Panel, Power Options and turning everything off there.
also turn on hibernation and see if that helps.
quick method for this is the powercfg -h off command from an elevated command prompt.
 
  • Like
Reactions: reasonabletan

reasonabletan

PCHF Member
PCHF Member
Feb 11, 2019
3
0
30
what is your OS?
have you tried going into Control Panel, Power Options and turning everything off there.
also turn on hibernation and see if that helps.
quick method for this is the powercfg -h off command from an elevated command prompt.

thanks but i ended up solving it by some google searches. i am posting it here so others might fine it useful.

  1. Click on the windows icon
  2. Type regedit
  3. Right-click on regedit icon, click Run as administrator
  4. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0
  5. Double click on Attributes
  6. Enter number 2.
  7. Go to Advanced power settings (click on Windows button, write power options, click on Power Options, in the selected plan click on the Change plan settings, click on the Change advanced power settings).
  8. Click on the Change settings that are currently unavailable
  9. Click Sleep, then System unattended sleep timeout, then change these settings from 2 Minutes to 20 for example.
That's it!
 
Status
Not open for further replies.