Solved Internal graphics not being put to use

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

maxim123

PCHF Member
PCHF Member
Aug 2, 2017
204
12
Hi, I have i3 g40 lenovo laptop. 8gb ram. 2gb(1gb? not sure dxdiag says 2 and system profile msinfo says 1 gb adapter ram) intel hd integrated graphics and 2 gb dedicated AMD radeon 8500M.
The problem is I only see the 2gb intel hd being used and not AMD as well. Is there a way to get both of them to work? My fps is current going 30-60 (spikes ) in league of legends (which is the only game I play) which has a low system requirements.
Do I need to install graphics card(probably external one since I play to upgrade my laptop in future) to increase the fps here, or can I do it by making AMD be in use too?

thank you :)
 
Last edited:

maxim123

PCHF Member
PCHF Member
Aug 2, 2017
204
12
I installed amd catalyst control. NOw it is showing render option in dxdiag which shows amd graphics options but it says render only display device. Does it mean that laptop is going to use amd when I play game now? but when I played league the amd system monitor shows no use of amd graphics:

Untitled.png


Untitled.png
 
Last edited:

maxim123

PCHF Member
PCHF Member
Aug 2, 2017
204
12
Hi, it seems to be working cause I see league of legends being on the application under amd radeon, but the only thing is there is no movement in amd radeon monitor. So still confused if it is working or not. The fps seems to be a problem of opening another software which uses a lot of memory. I am getting about 50-90 right now, is it good enough for this amd radeon dedicated graphics? is it being used?
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
726
160
27
Yeppoon, QLD, Australia.
I'm not 100% sure but I seem to recall with some laptops with an on-board motherboard graphics and an add-on card installed that one card will power the screen and the other the extra video-out port.
see if that has any legs.

otherwise what about just disabling the Intel card and forcing the AMD to be used as it's the only one.
 
  • Like
Reactions: maxim123

maxim123

PCHF Member
PCHF Member
Aug 2, 2017
204
12
I'm not 100% sure but I seem to recall with some laptops with an on-board motherboard graphics and an add-on card installed that one card will power the screen and the other the extra video-out port.
see if that has any legs.

otherwise what about just disabling the Intel card and forcing the AMD to be used as it's the only one.
how to do that without damaging the display if intel was the only card being used.
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
726
160
27
Yeppoon, QLD, Australia.
unless you have a hammer, there's no risk of damaging the display. :)
to disable one of the graphics cards, go into Control Panel (view by: small icons), Device Manager, expand Display Adapters and right click the one you want to disable.
 
  • Like
Reactions: maxim123

maxim123

PCHF Member
PCHF Member
Aug 2, 2017
204
12
unless you have a hammer, there's no risk of damaging the display. :)
to disable one of the graphics cards, go into Control Panel (view by: small icons), Device Manager, expand Display Adapters and right click the one you want to disable.
haha :D Thank you. the fps actually turned out to be same at 90 fps but a bit more stable i think, which is quite good right now.
Any update?
Thank you, it is solved now :)
 

phillpower2

Autonomous Admin
Administrator
Support Team
Sep 9, 2016
2,843
455
55
Glad to hear that the issue is resolved and thank you for the follow up maxim123 (y)
 
Status
Not open for further replies.