How To Make Setting For Autoplay

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Wendy

PCHF Member
PCHF Member
Jul 12, 2017
88
9
27
A friend gave me an old computer as a backup to mine. I've been trying to make it look like my regular computer but I 'm having a problem with autoplay. I use vlc media player on my "older" computer but when I insert a dvd in the "newer" computer it starts up windows media player. I figured out where to find the autoplay settings in the control panel. In my "older" computer I see it is set to play video (and audio) using vlc player. But in the " newer" computer that is not in the autoplay dropdown list. The only choice other than "take no action" and "ask me every time' is Windows media player. How do I put the vlc player in the dropdown list so that I can set that as the autoplay default? Both computer are windows 7.
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,294
1,823
pchelpforum.net
This link pretty well explains it. You could also set your required file associations to open with VLC.


Configure AutoPlay in Windows 7

It’s worth noting that in Windows 7 you can change the AutoPlay settings so that they mimic how it works in Windows XP. This is probably not something you would want to do, but it’s an option.


To configure AutoPlay, click on Start and type in autoplay. Select the first option at the top.


autoplay windows 7


This will bring up an absolutely giant list of items that you can individually configure. Thankfully, this list has been greatly reduced in Windows 10 as you’ll see below. Note that if you want to turn off AutoPlay completely in Windows 7, just uncheck the Use AutoPlay for all media and devices box at the very top.


windows 7 autplay configure


The reason I got the popup dialog when putting in my software CD was because Software and games was set to Ask me every time. You can change this to Install or run program from your media, Open folder to view files, or Take no action.


autplay options


The list of options to choose from will vary depending on what type of media is connected. For example, an audio CD or DVD movie will have the option to played using Windows Media Player. If you connect a device with pictures or videos, you’ll have the option to automatically import the items. In addition to the standard items, if you ever connected other devices to your computer like a smartphone or tablet, those will show up at the very bottom.
 

Wendy

PCHF Member
PCHF Member
Jul 12, 2017
88
9
27
I attached screenshots of both computers' Autoplay dropdown lists. I know about the vlc player preference set association setting but it doesn't work. When I set them they disappear as soon as I click "save". I looked at the "older" computer and when I click on set file associations a control panel opens up" Control Panel\All Control Panel Items\Default Programs\Set Default Programs\Set Program Associations". That shows the vlc player settings. But in the newer machine it does list not vlc player as an option when I click "change program". I attached a screenshot of that, too. I also included a screenshot of the specs of the newer computer that vger asked for.
 

Attachments

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,294
1,823
pchelpforum.net
Have you got vlc portable or installed version on the new pc?
 

Wendy

PCHF Member
PCHF Member
Jul 12, 2017
88
9
27
the vlc player is the same on both computers: 2.2.28 weatherwax
 

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,294
1,823
pchelpforum.net
That is not what was asked. Want to know if the copy of vlc on the pc that is given you a problem is an installed version, or a portable version.

Do this on the pc that is the problem child.

If there is an icon for vlc on the desktop please right click it and select properties on the box that appears

Click the shortcut tab on the new box that opens if it is not already

Please note the TARGET: and post it for us.

This is what is required although as an example only

2020-03-20_131931.jpg
 

Rustys

Escaped Mental Patient
Administrator
Support Team
Jul 22, 2016
2,432
635
127.0.0.1
pchelpforum.net
If I may inject here. See if this helps at all it did for me.

Go into the Control Panel
Make sure (upper right) View By is small or Large Icons
Select Default Programs
Top one should be Set Your Default Programs
On the left select VLC
Then on the bottom Choose Defaults for this Program
Put the Tic in Select All
Select Save
Select OK

Check to see if that has not corrected it for you like I stated it worked for me. You may also have to redo some of the auto play steps that are in Post # 3
 

Wendy

PCHF Member
PCHF Member
Jul 12, 2017
88
9
27
Gus: Sorry - I don't what a portable or installed version. I copied vlc player from my first machine but now I reinstalled it from the vlc player website. Still get the same result. But going to "set file association" now brings up the control panel "Set Program Associations " comes up. Evrything is checked - but nothing can be changed - i.e. unchecked. It's as if it is all locked in. But it still doesn't make a difference - windows media player still come sup every time. Here is the information you asked for:

Rustys: did what you suggested but it is the same as what I just write above for Gus. Everything already checked, nothing can be changed and it doesn't make a difference.
 

Attachments

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,294
1,823
pchelpforum.net
BTW, you cant copy installed programs from one pc to another.

the picture you posted indicates you have the installed version of VLC.

Heres a link on how to change associations on windows 7


Can I suggest again that you move onto a better player and install Pot Player which is more compatible with more different file formats than VLC.

Try this with VLC
Open VLC
Click the TOOLS menu
Click PREFERENCES on the box that opens
On the INTERFACE tab, scroll down the page and click SET UP Associations
On the box that opens select all the file extensions you wish VLC to play by default. You will have to scroll a few pages to see them all to select them
Once selected click APPLY
Then click SAVE on the Preferences page.


These are where you select the files to be associated with VLC



2020-03-23_134237.jpg
 
Last edited:

Wendy

PCHF Member
PCHF Member
Jul 12, 2017
88
9
27
I re-installed VLC froma VLC download and it doesn't help. As I wrote above, everything is already checked and none of them can be unchchecked or checked. Here is the screenshot of part of it. They're actually like a greyed check. Whys is this locked like that?? What you show me with clearboxes doesn't exist there. Evry box has a check but unchangeable checkbox. It's all loccked and Windows just doesn't pay attention to it.
 

Attachments

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,294
1,823
pchelpforum.net
Can you try another player to see if the same issue exists, suggest potplayer, much better than vlc.
 
Status
Not open for further replies.