How To Get Rid of Intrusive Facebook, Twitter etc. links overlays

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

User101

PCHF Member
PCHF Member
Sep 16, 2016
104
20
40
On some websites, the page contents are overlayed by links to Facebook, twitter et al that obstruct and prevent reading the page's contents. I expect these annoyances are set up by the website "designer" - it's beyond me why anyone would "design" a page so that it can't be fully read - and therefore nothing can be done to get rid of these overlays (see attached example) so that one can actually read the page. But I thought it wouldn't hurt to ask.
 

Attachments

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,376
1,835
pchelpforum.net
What browser are you using, and have you tried another browser to see if the problem still exists?
 

User101

PCHF Member
PCHF Member
Sep 16, 2016
104
20
40
I've had ublock origin on for a long time.

Good point about trying a second browser - I'm using firefox. Just tried it with Opera - and no overlay, at least not on the left side. None of those same links. But it has an overlay on the right side. It's not covering any text but I don't know if that is by "design" or because of the layout of the page there isn't any text there.
 

Attachments

gus

PCHF Administrator
Administrator
Security Team
PCHF Donator
Malware Teacher
Jul 19, 2016
4,376
1,835
pchelpforum.net
Not a Firefox user but a couple of things to try

Check your add ons for anything that doesnt stack up when you do a google search on it.

Restart Firefox with add ons disabled and see if the social media icons persist.

Go to options/privacy and adjust your settings to block cookies for social media sites and tracking content for all windows. These settings are in custom

You could also refresh Firefox to its default settings.
 

User101

PCHF Member
PCHF Member
Sep 16, 2016
104
20
40
Thank you gus. Good suggestions - but don't see "social media sites" as a choice for blocking cookies in options->custom.
 
Status
Not open for further replies.