Solved HDD not detected

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

TheMetalMessiah

PCHF Member
PCHF Member
Jan 20, 2020
5
0
24
A couple of days ago i have used windows reset 'till than everything was fine. After system reset laptop detects only SSD. When i enter bios and go to storage properties it says that SATA slots are empty. I havent touched internal components ever.
I have used intel assistant to instal all driver but still problem persists. Tried re installing windows but it gives me only SSD available. Even in disk management HDD is not detected. PLEASE HELP im stuck with 256gb :D
Laptop in question: MSI GE73 raider RGB 8rf
 

TheMetalMessiah

PCHF Member
PCHF Member
Jan 20, 2020
5
0
24
Yeah it definitely had HDD as (D) drive 1TB.
When i would play games at random i would get a black screen and sound going on speakers not on headphones which would go for like 2-3 sec than everything would start working normal... yes its under warranty. its like 5-6 months old..
It was working perfectly fine before i have reset windows.
Thanks for your time
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,147
199
Yeppoon, QLD, Australia.
was there data on D:\ ?
in Disk Management is the HDD not even showing up in the bottom section as Disk 1 (or something) ?
is all you see Disk 0 for the SSD and CD-ROM 0 for the DVD ?
 

TheMetalMessiah

PCHF Member
PCHF Member
Jan 20, 2020
5
0
24
Yeah D: have been about 70% full..
In disk management it doesnt appear.. anywhere...
I only see local disk (c:) without CD-ROM since there isnt any CD-ROM.
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,147
199
Yeppoon, QLD, Australia.
options:-
  • it's died - possible but unlikely
  • it's come lose of its connection inside - also unlikely as they are screwed into place (usually)
  • it's not a typical HDD but something else, like a hybrid drive (however, both should get drivers installed directly from Windows)
have you done a Windows Update?
have you reloaded all the system drivers from the CD or the MSI website?

because failing all that, I'd be removing the back plate and put the HDD into an external enclosure a) to see if that works and b) to recover data.
 

TheMetalMessiah

PCHF Member
PCHF Member
Jan 20, 2020
5
0
24
Yes fully updated windows, downloaded everything from MSI website. Tried updating with intel assisstant, updated asata drivers manually. So the next step is to open the back plate and trying if the cable is lose or discinnected? There usnt anything i can do software wise?
Kinda scared to open it but there is no workshop in serbia that fixes GE73 series for some reason
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,147
199
Yeppoon, QLD, Australia.
it sounds daunting but can be surprisingly easy (98% of the time) :)
YouTube some videos for your model first to get an idea on how it's done.
Some back plates unscrew, some slide off, some have access panels just for the memory and/or drives.
some even are accessible via the top by removing the keyboard - bit trickier but fairly straight forward still.
you do however need to be confident with screwdrivers and removing plastic mouldings etc.
 

TheMetalMessiah

PCHF Member
PCHF Member
Jan 20, 2020
5
0
24
I havent done a thing. Kind of gave up on it and searched for services in Romania. And last night i turned the PC on and boom... it works fine.. D: is showing up like nothing happened... what can it be?
 

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,147
199
Yeppoon, QLD, Australia.
complete guess, but perhaps an update has finally been downloaded and installed.
but hey, take the good surprises with the bad.
computers do that, ours is not to ask why!!! :)

good to hear it's sorted and thanks for letting us know.
 
Status
Not open for further replies.