Games FPS Suddenly Down

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
The only game I play is GTAV single Player at the moment. I was averaging about 120-150fps, after upgrading mobo to a MSI B450 Gaming Max Plus and upgrading CPU and RAM ,it seems like my game has taken a crap. I am only averaging a max fps of 60fps, it will NOT go over 60fps and since yesterday is dropping to around 30fps even though I've changed none of my settings in the game. Below is a list of my hardware a list of the old hardware and the new hardware. I will also include screenshots of the graphics settings that I currently have in GTAV. I'm running my CPU and GPU overclocked, and XMP enabled. I have 8 fans in my system so it can't be temperature, 3 120mm in front, 2 120mm top exhaust, 2 120mm on CPU cooler, 1 120mm back exhaust, dual fans on GPU running at 100% when gaming. All settings in game are set to the highest, I'm playing at a resolution of 1440 x 900 on a 4k TV.

Mobo: MSI B450 Gaming Max Plus ATX (upgraded from MSI B450 Pro M-2)
CPU: AMD Ryzen 5 3600 (upgraded from a Ryzen 5 2600x) (overclocked to 4.1 Ghz)
RAM: Corsair Vengeance LPX 16GB 2x8 ddr4 3600 (PC4-28800) (upgraded from Corsair Vengeance LPX 16GB 2x8 ddr4 3000) (XMP enabled for 3600Mhz)
CPU Cooler: Deep Cool GAMMAXX 400R
Case: Thermaltake V200
PSU: ROSEWILL Gaming 80 Plus Gold 550W Power Supply
GPU: EVGA Nvidea GeForce GTX 1660 Ti SC Ultra (overclocked with MSI Afterburner to Core Clock +120, Mem Clock +1000, Fan Speed 100%)
OS: Windoes 10 Pro 64
IMG_20200125_180212.jpg IMG_20200125_180236.jpg IMG_20200125_180253.jpg IMG_20200125_180308.jpg
 

Evan Omo

Computer Support Technician
Moderator
Support Team
Hi Brandon. Have you tried resetting all settings in the game back to defaults? Have you installed the latest video card drivers for your video card?

Try disabling all overclocking and see if there is any difference in the game performance.

Have you set your Windows power plan to high performance in the power options in Control Panel?
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
Thanks for the reply. So my power plan is set to Ultimate Performance (which I didn't even know existed, but then again this is the first time I've had a powerful rig). I did a little bit of messing around with the game settings, and it appears that vsync is enabled which explains why I'm not getting anything higher then 60fps (because my TV is 60Hz), but this doesn't explain why I was able to get around 150fps before I upgraded and did the Windows reinstall. I did disable vsync to see what would happen and weirdly it actually made it worse, by dropping my fps alot randomly to around 24-30fps (which I'm assuming shouldn't be happening with a overclocked 1660 Ti and a game resolution of 1440 x 900) I will say though that after messing with the settings in GeForce Experience and setting the graphics slider to about 3/4 of the way past performance (more towards graphics quality) I am now getting that 60fps and it's very smooth although I do notice a quality difference compared to when I was getting around 150fps.

TBH I haven't unOCed anything yet (i'm not sure how that would improve performance) I just have no idea why I'm not getting that 150fps anymore. To me it seems like having vsync enabled is basically making it so my gpu isn't being fully utilized and making it under perform, by forcing it to stay at 60fps when it could go alot higher than that. I know most people are going to think I'm being trivial and say if it runs smoothly and you aren't dropping frames and are at a steady high fps why bother, well because I was getting better performance and now I'm not, thats why.

As for resetting the games settings I did that and it defaulted to max settings at 4K, which is a little too much for my gpu, plus 4k is only at 24Hz so it looks like crap compared to 1440 x 900 at 60Hz. At this point the graphics quality is decent, I can live with it, but I just want to get that fps up. I heard about fast sync and heard it might help by unlocking that fps count so it can go over 60fps so I'd like to maybe try that, but what do you think about fast sync compared to vsync?
 

Evan Omo

Computer Support Technician
Moderator
Support Team
I would try disabling all overclocking on the card to make sure the card isn't throttling its clock speeds, set the video graphics options to high performance in the NVidia control panel, make sure V-Sync is off both in the NVidia driver settings and in the game settings itself and see if that makes any difference.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
Okay for some reason now vsync isn't in the GeForce Experience settings menu. I could have sworn it was there before, it's only in the ingame settings, and when I turn that off, it tanks my fps to around 30fps. Okay nevermind, I realized that:
1) I had vsync set to half, which was only maiking half of the 60fps, so thats why I was only getting 30fps
2) When I turned off vsync, I was getting high fps (around 120-150) but I was also getting some screen tearing, I'm assuming becuase my TV couldn't keep up with the in-gmae fps, so I turned it back on.
3) I only had my resoltuion set to 1440 x 900 at 60hz, I didn't realize I could change the hz becuase when I set it to 1920 x 1080 it was defaulting to 24hz, well I realized I could change it to 60hz, so now with vsync enabled and playing at actual 1080p 60hz, it looks awesome. Yes I'm not getting the full potential when it comes to fps from my gpu since I have to enable vsync, but the game still looks great, so it's nice to know though that if I decide to get a better tv with mybe 1080p 120hz that my gpu can still handle it. Thanks for the info, becuase I wouldn't have even realized I could change the hz for 1080p resolution. You can mark this solved.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
I would try disabling all overclocking on the card to make sure the card isn't throttling its clock speeds, set the video graphics options to high performance in the NVidia control panel, make sure V-Sync is off both in the NVidia driver settings and in the game settings itself and see if that makes any difference.
Well I'm glad I didn't close this thread. So it's not completely fixed. I stopped overclocking my GPU (it looks like I didn't really need it overclocked in the first place) I disabled Vsync and that got my fps way up but since my TV is only 60Hz I was getting alot of screen trearing so I reenabled it. I maxed out all settings but set the grass quality to normal and long shadows to normal, and set resolution to 1920 x 1080 60Hz. Everything seemed to be going fine but I'm getting random drops in fps to aroung 26-30fps when I drive through grassy fields, or even when I'm in the city and turn a corner. Basically it looks like it's dropping fps when i'm in a detailed enviroment. I'm really not sure what is going on. According to all the research I've done online my hradware should be having no problems running this game at everything maxed out, literally every site I've looked at said I should be able to run it with no problems. The one thing I'm wondering about is if maybe the problem is my RAM? I recently upgraded from 3000mhz to 3600mhz and this RAM is not listed in my mobo's QVL. It seems to be working fine, I have XMP enabled and it's running at just under 3600mhz, so i'm not really sure whats going one, i am really at a loss here. Is there some kind of test that I can run that would help you guys to help me out?
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
No, after disabling everything at startup the rockstar launcher won't launch, so it won't allow me to play the game, I have the Steam Version of it, I did reenable steam and tried starting the game through that but it just launches rockstar launcher which again doesn't launch, it says failed to connect to Rockstar games library, even though the rockstar launcher wasn't on the list for things for me to disable.
 

Brandon Byrnes

PCHF Member
PCHF Member
Jan 3, 2017
359
44
35
Wisconsin
Nevermind I found it. It seemed to work, I played for about an hour and it didn't seem to be dropping fps as much. It did it once in a while but definately not as much as before. I'm guessing now I'm going to have to go and enable the startup programs one at a time until I can figure out what is causeing the lag? That is going to be a major pain, since in msconfig it's showing about 30 different non Windows services that automatically start at startup.
 
Status
Not open for further replies.