Solved Games Crashing/Not Responding upon start

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Flysociety

PCHF Member
PCHF Member
Aug 10, 2020
2
0
25
Hello all, so very recently i have started to encounter an issue when i launch games, the initial Loading/splash screen for whichever game will appear, i get about 2-3 seconds of visual queues that the application is working, then i will see a indefinite freeze. If i have task manager open the application will almost always show "application not responding." There has not been much i have changed in my setup over the 2 years since i built my computer, but typically i have 3 monitors hooked up, i also have the 4th HDMI slot of my gpu running into an HDMI switch, on the OUT end of the HDMI switch i have one single 50ft HDMI that runs from my basement to my living room connected to my 4k display. So throughout the day my pc/applications/games will run fine. If i connect my HDMI switch so i can couch game on my tv all games will crash once i launch them. Ether they are Steam, Blizzard, or microsoft games. Even when i shut my switch off and try to run anything on my main display i have the same issue. I have updated graphics drivers, uninstalled/reinstalled steam, blizzard, same with all games. I have tried moving applications from one ssd to another. (i use two, 1tb and 500gb), updated windows. rolled back windows. Im by no means a "PC Guru" and i am very much so at a loss as to troubleshooting this issue. any feedback would be greatly appreciated. Thank you!

PS. i did post this thread in the "blue screen and crashes" forum page, but i felt this was the more appropriate place to post it.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
7,600
699
57
Glad you got it sorted and thanks for letting us know (y)
 
Status
Not open for further replies.