Solved CRITICAL_PROCESS_DIED BSOD

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
No, I don't have any Razer items. Never heard of Spycop before, so also no.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
Thanks, didn`t see either program in the list but had to ask.

To see if we can fix Windows, download then run the Windows All in One Repair tool from here, disregard the malware guidance but follow the other steps to the letter and in particular ensuring that you first create a new restore point and perform a proper Windows clean boot before running the repair, details for the clean boot here.
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
Ok, I have performed all the repairs, hopefully this works. Now we just wait again?
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
There should have been a repair log generated, can you find and upload it for us.
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
Sure, please find attached all the logs I could find.
 

Attachments

  • 24.10.2020_18.24.26.zip
    63.2 KB · Views: 2

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
I just had another BSOD, again ntdll. I was just starting the game again...


from the minidump:

*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

CRITICAL_PROCESS_DIED (ef)
A critical system process died
Arguments:
Arg1: ffff9083ac5241c0, Process object or thread object
Arg2: 0000000000000000, If this is 0, a process died. If this is 1, a thread died.
Arg3: 0000000000000000
Arg4: 0000000000000000

Debugging Details:
------------------


KEY_VALUES_STRING: 1

Key : Analysis.CPU.Sec
Value: 3

Key : Analysis.DebugAnalysisProvider.CPP
Value: Create: 8007007e on DESKTOP-ITI54DI

Key : Analysis.DebugData
Value: CreateObject

Key : Analysis.DebugModel
Value: CreateObject

Key : Analysis.Elapsed.Sec
Value: 3

Key : Analysis.Memory.CommitPeak.Mb
Value: 73

Key : Analysis.System
Value: CreateObject


BUGCHECK_CODE: ef

BUGCHECK_P1: ffff9083ac5241c0

BUGCHECK_P2: 0

BUGCHECK_P3: 0

BUGCHECK_P4: 0

PROCESS_NAME: services.exe

CRITICAL_PROCESS: services.exe

ERROR_CODE: (NTSTATUS) 0xaeeac040 - <Unable to get error code text>

CRITICAL_PROCESS_REPORTGUID: {c3ebded6-d519-4203-82be-57b03387e3f9}

IMAGE_NAME: ntdll.dll

MODULE_NAME: ntdll

FAULTING_MODULE: 0000000000000000

BLACKBOXBSD: 1 (!blackboxbsd)


BLACKBOXNTFS: 1 (!blackboxntfs)


BLACKBOXPNP: 1 (!blackboxpnp)


BLACKBOXWINLOGON: 1

CUSTOMER_CRASH_COUNT: 1

STACK_TEXT:
ffff8f86`82502938 fffff807`0bb06fe2 : 00000000`000000ef ffff9083`ac5241c0 00000000`00000000 00000000`00000000 : nt!KeBugCheckEx
ffff8f86`82502940 fffff807`0b9d7d83 : 00000000`00000000 fffff807`0b460ea5 00000000`00000002 fffff807`0b460dcf : nt!PspCatchCriticalBreak+0x10e
ffff8f86`825029e0 fffff807`0b84a9b0 : ffff9083`00000000 00000000`00000000 ffff9083`ac5241c0 ffff9083`ac5245f8 : nt!PspTerminateAllThreads+0x1ee377
ffff8f86`82502a50 fffff807`0b84a7ac : ffff9083`ac5241c0 00000000`00000000 00000004`a047fc3c fffff807`0b90470a : nt!PspTerminateProcess+0xe0
ffff8f86`82502a90 fffff807`0b605fb8 : ffff9083`ac5241c0 ffff9083`aeeac040 ffff8f86`82502b80 ffff9083`ac5241c0 : nt!NtTerminateProcess+0x9c
ffff8f86`82502b00 00007ff8`5766c314 : 00007ff8`576e2693 00007ff8`57711364 00000004`a047fc00 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x28
00000004`a047ea08 00007ff8`576e2693 : 00007ff8`57711364 00000004`a047fc00 00000000`00000000 00007ff8`575d0000 : 0x00007ff8`5766c314
00000004`a047ea10 00007ff8`57711364 : 00000004`a047fc00 00000000`00000000 00007ff8`575d0000 00000000`00000004 : 0x00007ff8`576e2693
00000004`a047ea18 00000004`a047fc00 : 00000000`00000000 00007ff8`575d0000 00000000`00000004 00007ff8`5767331d : 0x00007ff8`57711364
00000004`a047ea20 00000000`00000000 : 00007ff8`575d0000 00000000`00000004 00007ff8`5767331d 00007ff8`57711364 : 0x00000004`a047fc00


STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: 0xEF_services.exe_BUGCHECK_CRITICAL_PROCESS_aeeac040_ntdll.dll!KiRaiseUserExceptionDispatcher_IMAGE_ntdll.dll

OS_VERSION: 10.0.19041.1

BUILDLAB_STR: vb_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {d1a1f76a-bd85-a29e-fbe0-c5317a9e0a06}

Followup: MachineOwner
---------
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
37 repairs carried out by the AIO tool, not a record but still a lot

Question, does the issue only ever happen when you are connected to the Internet.

This seems to have completed the Windows updates?

I`m only seeing the three updates now and none for Windows 10 itself :unsure:
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
I`m only seeing the three updates now and none for Windows 10 itself :unsure:

When I check the update history they're still displayed in Dutch rather than English. Maybe Speccy is unable to find them after the change of language?

I'm always connected to the internet, so I would say yes.
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
Correct, I added it with an edit, sorry about that. But yes, I'm always connected to the internet.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
Thanks, for confirming (y)

Update the BIOS to the latest version 2802

Download and save the latest version 12.18.9.7 LAN drivers, create a new system restore point, uninstall the present LAN drivers, restart the computer in Safe Mode only (No Networking) install the new LAN drivers that you saved, restart and use the computer as you normally would to test, post back with an update when you are ready.

Both of the above are available to download from here
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
Just to be sure, I have to uninstall the present LAN drivers by going to the device manager and then click uninstall, right?
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
So far so good but I noticed a new error in the event logger. Please see the screenshot. I tried to Google how to get rid of it all together but can't find anything. Any tips?
 

Attachments

  • screenshot.png
    screenshot.png
    141 KB · Views: 5

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
You will always see some error or another in Event Viewer and unless it says critical and your computer is having issues you should disregard them.

Being honest it would save folk a lot of stress and forum helpers a lot of time if users were not able to access such things as Event Viewer without the help of a tech, people see minor issues then start tinkering and nine times out of ten they end up hosing Windows for no reason.
 

JensDc

PCHF Member
PCHF Member
Oct 17, 2020
28
0
28
Ok, I see. Thanks for the info and sorry. Was just wondering because it started after I disabled the services for the AIO tool.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
8,079
723
57
If the computer is no longer in a clean boot state and you are not having any issues I would leave well alone tbh.
 
Status
Not open for further replies.