• Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Status
Not open for further replies.

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
This latest crash was USB related and namely USBXHCI.sys which is nothing to do with your RAM or your Samsung device.

If your second stick of RAM is the exact same spec as the present 2666MHz stick you should insert it into slot B2 so that both sticks of RAM are populating the two slots as is shown in the attachment in my reply #35.

Once you have inserted the RAM, restart the computer, go into Device Manager and check for any yellow ! or red X against any of the USB devices, be sure to click on the View tab so that you can check for any in the Hidden Devices option as well, once done, run Speccy and post the new url for us so that we can check that your RAM is behaving as it should.
 
  • Like
Reactions: Exyztence

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
I will do it today and I will make update for you later with speccy URL. Btw, XMP is turned off in bios, should I turn it on?
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
XMP needs to be enabled else the RAM will only run at the stock speed of 2133MHz.
 

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
Hi.
Tomorrow I'm going to meet with my friend and we'll put those ram sticks. Btw, for today, I made dual boot on my Pendrive with ubuntu 20.04 on it and I will leave my PC overnight and see if there are any BSOD. My other friend told me that Linux will show much more info about a bad driver when my PC crashes in /var/log and in ,,demsg". What do you think about that?
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
Windows and Linux do not use the same drivers so there is no comparison I`m afraid, running Linux to see if a computer still crashes is something that we often do btw.
 

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
Hello.
Unfortunately, Linux gave no crashes even though I left it overnight for about 10h. On windows, I mostly have BSOD just after 2 hours.
Today I will put in this stick of ram (2666) and enable XMP in BIOS, then check in device manager if I have any yellow !'s or red X's, and after, I will post a speccy URL.
I will update you as soon as possible.
Greetings,
Oliwer.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
Proves that your single stick of 2666MHz RAM is ok but without the other things being done and the computer then being used as it normally would be it is not possible to comment further.
 

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
Hi. Tomorrow I will give u Speccy URL, because I fitted my RAM but I'm heading to bed. x4 8gb ram right now, slot 1 and 3 is stick with 2133, 2 and 4 is 2666. XMP enabled.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
Sorry but that is not what you were advised that you needed to do :(

As per my reply #4;

You have incompatible RAM for your i9 9900K CPU which requires a minimum of DDR4-2666MHz, specs here you have two sticks of 2133MHz RAM fitted which is bottlenecking your unlocked processor, to resolve this you need to get rid of the slower RAM

All you have done is increase the amount of slow RAM you have and is not in with keeping with what you said that you intended upgrading to;

Hi!
Wow, literally I didn't know that info about my ram. When I was buying it, there was written it is 2666mhz but when I checked now in speccy it is 2133.
I have changed my power plan to balanced.
What should I do now? I can without any doubt buy new ram, this one would be okay?

Thanks for your response!
 

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
But with XMP enabled, shouldn't this ram be sped up to 2666?
Then I will put only 2x 2666 right?
Btw, the BSOD still happens even when I don't have 2133 ram, so is it really the point?
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
If you put two different speeds of RAM in a MB the faster RAM is automatically clocked backwards to the speed of the slower RAM, XMP does not and cannot make any difference, the slower speed of RAM is not capable of running at the faster speed whereas the faster RAM is easily slowed down to match that of the RAM with the lower clock speed.

Put only the two sticks of 2666MHz RAM in the A2 and B2 slots as has been previously advised.

Check in the BIOS that the RAM is running at 2666MHz.

Any further crashes after doing the above.

Post a new Speccy url.

Upload any crash dmps that have happened since you only had the correct speed of RAM in the board.
 

phillpower2

PCHF Administrator
Administrator
Support Team
Sep 9, 2016
9,060
803
57
RAM is working as it should and has no issues.

The latest crash dmp doesn`t say anything specific and only mentions "system" and "nt" which are generic (useless)

The other dmp mentions USBXHCI.sys again but in addition it this time flags up Razer synapse service which is a well documented problem with Razer software (a common thorn in the side).

Suggestions and a couple of links for you below;

Uninstall all Razer software.

Disconnect all Razer hardware from the computer.

Use a generic mouse and keyboard, use the computer as you normally would to see how things go.

In addition to the above;

Once you have gotten rid of the Razer software and are using a generic mouse and keyboard;

Go here to see if there is any firmware update for your Samsung SSD.

Download the Samsung magician software from the same Samsung link above.

Use the Samsung Magician tool kit to test your SSD.

Post back with an update when you are ready.

Razer info at links here and here

Still seeing the multiple AVs in Speccy so have to be honest and inform you that if you still have issues after doing all of the above you have no other option than to clean install Windows, the MBs chipset and storage drivers and finally the GPU drivers.

To continue while we are still seeing the multiple AVs would be an act of stupidity tbh as we have been jumping through hoops trying to solve this latest issue and until the multiple AVs are gone we have no way of knowing if them conflicting is causing the DPC_WATCHDOG_VIOLATION (133) errors

After clean installing Windows 10 I would strongly suggest that you stick with the perfectly good Windows Defender and Firewall, you will be/are avoiding creating potential conflicts and taking advantage of one of the best AVs & firewall that you can get, neither are free as you paid for them when you purchased Windows itself which is one of the reasons that both are well supported.

Firewall
Firewall: Enabled
Display Name: ZoneAlarm Extreme Security Firewall
Antivirus
ZoneAlarm Extreme Security Antivirus
Antivirus: Enabled
Virus Signature Database: Up to date
Windows Defender
Antivirus: Enabled
Virus Signature Database: Up to date
ESET Security
Antivirus: Enabled
Virus Signature Database: Up to date
 
  • Like
Reactions: Exyztence

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
After your message, I plugged out my mouse pad (I had a razer RGB mouse pad) and my PC has 9-hour uptime. It never lasted for so long so maybe it is the solution. I will also leave my PC overnight to check if it resets, hope it will not.
I will update you when something happens! :)
 

Exyztence

PCHF Member
PCHF Member
Apr 11, 2020
126
0
24
Hi,
so my PC lasted whole night, so I think it might be the solution but I did two things:
1. uninstalled razer synapse
2. unplugged all USBs
I installed Razer drivers before and it didn't help, but this time I also unplugged all the USBs, which might be the solution I bet.
Is there any way to check if I have any USB port broken or something?
 
Status
Not open for further replies.