Solved Audio delay in Videos and Streams

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Status
Not open for further replies.

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
Hello,


The audio is delayed, i don't know how this started, but the video is a TWITCH STREAM and when i start watching or i refresh the page the audio is perfect, after a few mins starts the delay. I also noticed in YOUTUBE or other videos in other websites.

I tried all this:

Chrome and Firefox: Same problem
Incognito mode: Same problem
Without plugins: Same problem
Disabling devices in Device Manager

I reinstalled all the audio drivers from Device Manager. I did a clean installation of Nvidia drivers

I don't know what else do to, this started happens a few days ago for no reason.

PC:
i7 7700k 4.20
16GB DDR4 RAM
NVIDIA GeForce GTX 1070 8GB
Motherboard MSI Z270 Gaming M5

THANKS IN ADVANCE!

Edit: external links removed
 
Last edited by a moderator:

Bruce

Forum Regular
Support Team
PCHF Member
Oct 8, 2017
1,477
235
Yeppoon, QLD, Australia.
this only happens when watching online streaming videos?
try a downloaded, or one already on your PC, and see if it happens.

have you changed the youtube settings quality to SD instead of HD?
have you rebooted your modem?
try creating another user account, log in on that and see if that helps.

have you started the browser in safe mode (not the PC).
Firefox for example is done by holding down the Shift key while you start it.
 

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
Hello

What OS are you using?

@Bruce
Hello! W10 Enterprise.

I had a video in the post but i think it was removed, showing the problem exactly.

If you guys allow me, i can post it again. Sorry it if was against the rules.


this only happens when watching online streaming videos?
try a downloaded, or one already on your PC, and see if it happens.

have you changed the youtube settings quality to SD instead of HD?
have you rebooted your modem?
try creating another user account, log in on that and see if that helps.

have you started the browser in safe mode (not the PC).
Firefox for example is done by holding down the Shift key while you start it.
This only happens in streams like Twtich, and videos like Youtube or other platform like dailymotion.

About the youtube quality, well it also happens in Twtich, and i tried other quality, few streamers only streams at 720p other at 1080, same with youtube.

The modem yes, i also tried with another connection, i have 2 installed in my home.

Gonna try the user, not exactly sure how it works because my PC goes to desktop without asking me any users before.

I'm not sure what safe mode is, but i tried WITHOUT plugings, and in incognito mode. I only use Chrome, i downloaded Firefox to fix this so it's by default, i only went to Twtich and after a few mins the delayed started.
 

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
2,693
650
127.0.0.1
pchelpforum.net
Kind of a known issue right now. Some users systems do the same thing where as their tablet and phone do not.
Wired or Wireless
What speeds are you getting and compared to what you are suppose to
If Wireless then what happens if wired
Have you reset the network settings on your system
Is this the only system that is affected (do other devices/system)

EDIT: Might also try turning off Use hardware acceleration when available with in the browser
 
Last edited:

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
Kind of a known issue right now. Some users systems do the same thing where as their tablet and phone do not.
Wired or Wireless
What speeds are you getting and compared to what you are suppose to
If Wireless then what happens if wired
Have you reset the network settings on your system
Is this the only system that is affected (do other devices/system)
Hello!

The connection is wired, i have 300/15 and according to Speedtest is all correct, i just did the test and got 9 ping, 311/17.

I did not reset the network setting, how i do this?

I also have a Notebook that i use WIRELESS, its connected at the same connection (300/15) and i DO NOT have this problem. Only in the PC for what i have seen. I'm gonna try in my cellphone.
 

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
I just did the test

30 mins in cellphone, no problem at all (wireless)
30 mins in the PC, delay after a few mins (wired)
 

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
2,693
650
127.0.0.1
pchelpforum.net
I did not reset the network setting, how i do this?
Open an Administrator Command Prompt

Type the following commands, pressing Enter after each command:

ipconfig /flushdns
ipconfig /release
ipconfig /renew
nbtstat -R
nbtstat -RR
netsh int reset all
netsh int ip reset c:\resetlog.txt
netsh int ipv6 reset
netsh int ipv4 reset
netsh winsock reset catalog

Reboot the computer

Sometimes running more than one firewall / antivirus program at the same time can cause issues like this.

Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s.

To publish a Speccy profile to the Web:

In Speccy, click File, and then click Publish Snapshot.

In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.

Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.

You could also attempt a Clean Boot to see what is giving you the issues.

 

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
Open an Administrator Command Prompt

Type the following commands, pressing Enter after each command:

ipconfig /flushdns
ipconfig /release
ipconfig /renew
nbtstat -R
nbtstat -RR
netsh int reset all
netsh int ip reset c:\resetlog.txt
netsh int ipv6 reset
netsh int ipv4 reset
netsh winsock reset catalog

Reboot the computer

Sometimes running more than one firewall / antivirus program at the same time can cause issues like this.

Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s.

To publish a Speccy profile to the Web:

In Speccy, click File, and then click Publish Snapshot.

In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.

Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.

You could also attempt a Clean Boot to see what is giving you the issues.

Thank you very much, here's the URL: http://speccy.piriform.com/results/kBHYLTvdMaQKZHCKYKS7GjA
 

Rustys

PCHF Administrator
Administrator
Support Team
Jul 22, 2016
2,693
650
127.0.0.1
pchelpforum.net
Why do you have Windows 10 Enterprise 64-bit installed on the system.

From what I can see in the speccy report

You will need to free up some space Windows 10 require 25%-30% free space on the C drive for windows to properly work and preform updates.
Partition 1
Partition ID: Disk #1, Partition #1
Disk Letter: C:
File System:NTFS
Volume Serial Number: 722676D0
Size: 118 GB
Used Space: 90 GB (76%)
Free Space: 27,5 GB (24%)

Active power scheme: High performance
We suggest that you change the Windows Power Plan to Balanced, High Performance is a form of overclocking that is known to cause stability and overheating issues and the setting should only be used for gaming type notebooks that have a discrete GPU that needs the extra power.

Look like there was an infection and there is still some left overs still there and you will need to contact you IT department for them remove that.
 

Lacryman

PCHF Member
PCHF Member
Jul 8, 2020
6
0
33
Thanks a lot for your time.

Yesterday my internet went down, and when came back the problem was solved :/ the delay is gone, i guess was something related with the modem/connection
 
Status
Not open for further replies.