• Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ASUS Z170 Pro Gaming Ram XMP failure on i7-6700 and i5-7400

Not open for further replies.


PCHF Member
Jul 28, 2019
System Specs:
Motherboard: Asus Z170 Pro Gaming BIOS version 3805 5/16/2018
Processor: i7-6700 with box cooler
RAM: Kingston Hyper X Fury 2666 MHz 2x8 GB (Slots A2 and B2)
PSU: EVGA Supernova B3 550 Watt 80+ Gold
Boot: Patriot Burst 240 GB 2.5" SSD
Storage: Hitachi Deskstar 1TB 3.5" HDD
Windows 10 Pro 64 bit

The issue: I cannot figure out how to XMP any ram on this board. I select any ram speed over 2133 MHz with or without XMP and it will not boot, it gets stuck on the DRAM LED with no beep codes and I have to force shut down. System works fine otherwise at 2133 MHz.

What I've done:
Tried SEVERAL different RAM kits. Such as: Corsair Vengeance LPX 3000 MHz 2x8 GB. ADATA XPG Z1 2666 MHz 2x4 GB, and Non-XMP RAM like Teamgroup Elite 2400 MHz 2x8 GB.
Tried a single stick of RAM in each slot.
Tried a different processor - i5-7400 - I was able to get the RAM to go to 2400 MHz with this processor since that is the max supported speed by default on this processor. Anything higher - same issue.
I made sure the XMP profiles set the correct timings and DRAM voltages - they are correct with each RAM kit.
Tried the following suggestions that I found by searching:
CPU VCCIO voltage - 1.15v
CPU System Agent voltage - 1.15v

I'm out of ideas.

Here's a speccy of this system for those of you who know what to do with it.

Thanks in advance!
The i7-6700 is locked and therefore not compatible with RAM any faster than 2133MHz and trying to set it any higher is causing POST to fail, this the reason why the same thing happens when you try increasing the RAM speed past 2400MHz with the i5-7400 which is likewise also locked, the solution is to get yourself an unlocked k version CPU.
Thank you for your reply

That had crossed my mind, but when I check the RAM specs for the i7-6700k, it also says the max RAM speed is 2133 MHz. Likewise, the i7-7700k says the max supported RAM speed is 2400 MHz. Would be kind of pointless to include the XMP feature on a board that doesn't support any processors that support XMP...
I know I'm not allowed to include links to other websites, but I have read numerous cases of people overclocking their RAM with this exact processor. Also, I have overclocked RAM on locked processors before with a Z series board. I overclocked RAM on a i5-4690 to 2133 MHz on a Z97 chipset where the max RAM speed supported by the processor is 1600 MHz. I have also overclocked RAM on a i3-8100 on a Z370 Chipset to 3000 MHz where the max RAM speed supported by the processor is 2400 MHz. I know this is doable... I'm just not sure how.
But the k version can be overclocked accordingly whereas the non k version cannot.

The BIOS will only recognise the serial presence detect maximum of 2133MHz that is appropriate for the i7-6700 and anything above this the BIOS will reject it.
Then why am I able to overclock RAM on other locked processors with older and newer chipsets? And why are other people able to overclock their RAM on their i7-6700s with Z170 chipsets? And technically XMP profiles can increase the base clock of the processor in some cases, which I can do on this processor, I just cant increase it any higher than the max turbo frequency - which is the benefit you get from an unlocked processor. A great example of this is when you overclock to 3000 MHz. Without an increase in the base clock you get 2933 MHz unless you either force it to run at 3000 MHz or increase the base clock to 102.5. My wife's computer with an i7-8700 was a great example of this. She had a Z370 chipset with 3000 MHz RAM. The spec sheet says this processor only supports 2666 MHz RAM. When I enabled the 2nd XMP profile for 3000 MHz it increased the base clock to 102.5. When I enabled the 1st XMP profile for 2933 MHz the base clock is still the default 100. The computer ran great on either profile. Come to think of it I have another build I just did with the i7-8700 and 3000 MHz RAM on a Z390 chipset.
Not saying that the RAM cannot be overclocked only why the computer will not POST when the values of the RAM have been changed, it is the BIOS that is having a problem with the overclocking.
You are seeking help at multiple forums, which can be counter productive and confusing. A quote of yours from an identical thread elsewhere.

"I know this might be frowned upon since I'm coming to a forum for help and am essentially looking to profit from your knowledge, but I build gaming computers (All computers actually) as a home business. I wanted to be able to sell this unit with the RAM running at the advertised speed and this will be the second Z170 motherboard I've had issues with getting RAM to run in anything over the 2133 MHz on a 6th generation processor."

is in conflict with the rules of PCHF which you agreed to when you joined.

15. PCHF can not and will not offer advice for business use or financial gain. PCHF only offers assistance for personal use.

Thread closed
Last edited:
Not open for further replies.