All games on my pc keep crashing or running 10 fps.

  • Hi there and welcome to PC Help Forum (PCHF), a more effective way to get the Tech Support you need!
    We have Experts in all areas of Tech, including Malware Removal, Crash Fixing and BSOD's , Microsoft Windows, Computer DIY and PC Hardware, Networking, Gaming, Tablets and iPads, General and Specific Software Support and so much more.

    Why not Click Here To Sign Up and start enjoying great FREE Tech Support.

    This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Status
Not open for further replies.

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
hello everyone I built my first gaming PC last month and now its having problems. I built the pc and everything was fine until I added more ram and my aio. When I installed my new parts battlenet was saying that it couldn't find my games on my pc even though they were downloaded. After redownloading them the game would work but now the games have started crashing mid game. I updated my drivers, reset bios, uninstalled and reinstalled the game twice and it doesn't crash anymore but my fps drop to 10 for like 5 minutes and then recovers. I wondered if it was just warzone but I tried my other call of duty games and the same thing is going on. I am at a loss, any suggestions?
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
Hello

Provide us with your complete pc spec's and including the psu spec's.
Processor: AMD Ryzen 5 2600 Six-Core processor 3.4 GHz
Ram is 32Gb XPG
Graphics card is Geforce gtx 1660ti
PSU: seasonic X-850 SS-850KM3 Gold 850W
Motherboard: Gigabyte B550M aorus pro AM4 AMD B550 micro-atx
64bit operating system
on windows 10
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
Processor: AMD Ryzen 5 2600 Six-Core processor 3.4 GHz
Ram is 32Gb XPG
Graphics card is Geforce gtx 1660ti
PSU: seasonic X-850 SS-850KM3 Gold 850W
Motherboard: Gigabyte B550M aorus pro AM4 AMD B550 micro-atx
64bit operating system
on windows 10
Also I forgot to mention in the first post about a month after use my pc upon start up would give input to the monitor and then stop. Once I hit the restart button on the pc it boots up fine but the first time never boots up properly. When we first set up the pc it has never been able to detect the other memory I have a solid state drive (western digital 500GB) and it detects it but not the non solid state drive memory (Western Digital WD AV-GP 500GB).
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
Ok explain the memory setup.
The setup is two external hard drives, one solid state drive (western digital 500GB) and it detects it but not the non solid state drive memory (Western Digital WD AV-GP 500GB).
 

Bruce

Forum Regular
Moderator
Support Team
Oct 8, 2017
2,791
373
Yeppoon, QLD, Australia.
was the new RAM the same make/model/speed of the old RAM?
does is go back to normal if the new RAM is removed?

and we aren't getting memory mixed up with storage are we?
you say the first boot never detects the other memory then go on to describe the drives.
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
was the new RAM the same make/model/speed of the old RAM?
does is go back to normal if the new RAM is removed?

and we aren't getting memory mixed up with storage are we?
you say the first boot never detects the other memory then go on to describe the drives.
The new ram is the exact same specs. The same occurrence happens without the new ram. The boot and the storage are two different problems. I'm really not too worried about the storage not detecting I would rather focus on the other problems. I didn't know if it could possibly all be the same issue or if its completely different problems.
 

Bruce

Forum Regular
Moderator
Support Team
Oct 8, 2017
2,791
373
Yeppoon, QLD, Australia.
while FPS is not really my area, and it always seems to be Holy Grail of gaming, the fact the it is fine, drops for 5 odd minutes then goes back to normal, would to me suggest some background task is kicking in, doing it's thing then going away.

try disabling all background, scheduled tasks.
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
while FPS is not really my area, and it always seems to be Holy Grail of gaming, the fact the it is fine, drops for 5 odd minutes then goes back to normal, would to me suggest some background task is kicking in, doing it's thing then going away.

try disabling all background, scheduled tasks.
Okay I will try that when I get home. What do you think about the start up issue. Sometimes when I turn it on it literally only turns the rgb for everything on and doesn't give any input. It is very odd to me and I really don't know where to start looking for the problem.
 

Bruce

Forum Regular
Moderator
Support Team
Oct 8, 2017
2,791
373
Yeppoon, QLD, Australia.
I agree with your assessment from earlier - let's focus on one issue at a time. :)

but... it could be as simple as the PSU not being fully compliant with the motherboard.
or failing hardware.
 

ebencic2

PCHF Member
Oct 19, 2021
7
0
21
I agree with your assessment from earlier - let's focus on one issue at a time. :)

but... it could be as simple as the PSU not being fully compliant with the motherboard.
or failing hardware.
How would be the best way to diagnose which it is?
 

phillpower2

Administrator
Support Team
Sep 9, 2016
10,327
880
the non solid state drive memory (Western Digital WD AV-GP 500GB).

That is a budget mechanical hard drive from 2010 and being that WD Green drives only had/have a three year warranty it has done well to even still being around.

Do the below for us first then if you are able to access the drive, back up what you need from it then run the WD Lifeguard/Dashboard Utility on it.

Download then run Speccy (free) and post the resultant url for us, details here, this will provide us with information about your computer hardware + any software that you have installed that may explain the present issue/s.

To publish a Speccy profile to the Web:

In Speccy, click File, and then click Publish Snapshot.

In the Publish Snapshot dialog box, click Yes to enable Speccy to proceed.

Speccy publishes the profile and displays a second Publish Snapshot. You can open the URL in your default browser, copy it to the clipboard, or close the dialog box.
 
Status
Not open for further replies.